Block frequency on Ropsten is now back to normal. Difficulty on the network is still abnormally high, but all our nodes are functioning as expected.
Posted Jul 03, 2019 - 13:46 UTC
Update
The frequency of new blocks appear to have slowed down to more normal levels. We will continue monitoring.
Posted Jul 03, 2019 - 11:08 UTC
Monitoring
We are still monitoring the situation on the Ropsten testnet.
Posted Jul 03, 2019 - 09:22 UTC
Identified
The issue has been identified as a possible reorg-attempt/attack on the Ropsten blockchain.
This attack will affect any sites/services using the Ropsten testnet globally. As this is an attack on the Ropsten network itself, we are not able to take any action against it as it is beyond our scope.
We are investigating an issue on the Ropsten testnet where blocks are coming in way more frequently than normal. This may affect Chainlink nodes on the Ropsten testnet, though it appears to be a network-wide issue.